Recent Posts

Pages: [1] 2 3 ... 10
General Support / Re: CW Keying on Remote K3
« Last post by w8rj on Today at 03:30:40 pm »
You could try reloading the firmware on the radio, but I really, really doubt that would help. I can't think of any setting that would result in what we are observing.

To get a real test on how the server is responding to polling the status of the radio, you need to be at the radio and manipulate the control on the radio and see how fast the Client reacts. There a few controls that may not respond at all. But TX or a Mode change should be reflected on the client. There shouldn't be any more of a delay more than a second or two.
It's only active when you're connected to a remote.
General Support / Re: CW Keying on Remote K3
« Last post by n2bhd on Today at 02:58:56 pm »
I removed AVAST, but no improvement in TX button delay.

After I tap the CW key, and the TX button sticks ON, that I can click on other buttons, and the K3 responds appropriately.  I changed filters, and the audio BW responded.  I changed modes, and the radio responded.  I tried the A/B button, and the frequencies on the display swapped.  But the TX button stayed on throughout all the changes.

I connected as W2OW from the the RCForb client on the same PC that the RCForb server is running on.   So I had two connections (W2OW and N2BHD) to the server from different PCs.  When I tapped the CW key, both clients showed the stuck TX button.  When I clicked other radio buttons on the W2OW client, the N2BHD client displayed all the radio changes immediately, but the TX stayed ON on both clients.  So it seems like both clients were polling and receiving the correct radio state.

I wonder if the K3 might be reporting the wrong TX state when the RCForb server reads the status.  I tried changing QSK to both Full and Semi, but no difference.  Is there something in the K3 Config that could cause this?

Done.  However, Device Manager does not see the new port, Com7 and neither does Commander.

Device Manager shows:
ELTIMA Virtual Serial Port (COM5 -> Com6) -- and --
ELTIMA Virtual Serial Port (COM6 -> Com5) -- just the way Brandon set it up.

It does not show Com7 I just created.
The error indicate you miss-configured the K3 VCOM port. This port needs to be setup as a Virtual Port.

When you have the VCOM setup dialog, first click on "Use Existing Port" and pull down the Serial Port dropdown and select "Disabled".

Click on the Create Virtual Serial Port and pick a Com number. That will be the comport to hook your logging program up with.
General Support / Re: CW Keying on Remote K3
« Last post by n2bhd on Today at 01:33:03 pm »
The CW feature hasn't been used for quite a while.  The last time I tried it was probably around a year ago, and I don't recall such a long TX button delay.  I have an elderly club member who wants to use the remote with CW, so I was just checking things out to make sure they still worked.  I have routinely installed RCForb client and server updates, but not much else (besides the AVAST automatic updates).  I did install TeamViewer v13 a couple of months ago, but it didn't work with Win XP (some known bug), so I reinstalled TeamViewer v12.  Since very few S/W companies are still supporting Win XP, I have been reluctant to install other S/W updates.

I will  uninstall AVAST, and see if there is any change.

Thanks & 73,
TU very much Roger.  That's the way it is set up.  I have the Mini and the host in sync.  However, Commander is not "connected."  Com5 is the port used in the Control Device Setup pane.  The other "end" of the serial port pair, Com6, was set by Brandon (and still is) top be the port to which Commander connects.

When I load PCFOrb the error is " Unable to start Eelcraft K3 emulation on physical serial port.  Access to port COM6 is denied.
General Support / Re: CW Keying on Remote K3
« Last post by w8rj on Today at 12:58:44 pm »
The change in the speaker slider, the Client is resetting levels to ensure you hear the remote radio's sidetone.

Even if the CW routines is accidently leaving the TX button activated the polling of the radio should turn it off pretty quickly.

It get's back to a serial port issue, or maybe a Flash Player issue, or .NET issue.

Did this behavior just start and if so did you install  any new software? You did mention that AVAST updated recently. I would go ahead and remove it completely. No telling what some of these anti-virus software packaged do.
These instructions are for V8 of the Client

When you plug in the K0 Mini to the computer, there should be two new serial ports showing in the Device manager.

Lets say they show up as Com10 and Com11. 

The Remote Head, PTT and External CW all should be set to the lower Com number (COM10). Make sure you enable all.

For your logging software setup the K3 VCOM to Create a Virtual Serial Port and that is the Comport you connect to from your logging program.

If you plug your mini into a different USB port the Com number will probably change. So use the same USB port all the time.
General Support / Re: CW Keying on Remote K3
« Last post by n2bhd on Today at 12:28:26 pm »
Hi Roger,
I just verified that I can hear the CW from the W2OW K3 here at home on my TS-2000, so it seems to be TXing the CW.  On the K3, the VOX button needs to be on before it will TX CW.

Did you experience the strange speaker audio level, where after the CW key is released, the audio doesn't return to the level indicated by the slider?

Pages: [1] 2 3 ... 10