Author Topic: Embedding in your own Webpage (Google Gadget)  (Read 40106 times)

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2460
Re: Embedding in your own Webpage (Google Gadget)
« Reply #45 on: April 25, 2016, 05:28:53 am »
Under Options->Audio Configuration, 3rd party solutions select Unreal Media Server (Flash Player).
In Domain/Host put your outside IP of your server.

If you want to stream audio (just RX) to the webpage see this post about setting up Unreal Media Server.
http://www.remotehams.com/forums/index.php/topic,16.msg18.html#msg18

Make sure port 5119 is opened and forwarded. Also make sure the Windows firewall has an exception for the Unreal Media server.





73
Roger
W8RJ

Offline ny4i

  • Remote Enthusiast
  • ***
  • Posts: 32
Re: Embedding in your own Webpage (Google Gadget)
« Reply #46 on: December 03, 2017, 09:29:23 am »
I concur in that I just see donation text and info about the server but not the status.

Plus, if one is not logged into the RemoteHams website, instead of seeing the donation text, a login text field is displayed (user and password).

I'm looking to simply host an iFrame if the same status on the Google Map on our website but the user would not be logged in. Is this possible?

Thanks,

Tom NY4I
Tom NY4I

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2460
Re: Embedding in your own Webpage (Google Gadget)
« Reply #47 on: December 03, 2017, 09:44:44 am »
If you allow Guests on your server (Options->Server Configuration), you can just dismiss the login on the web gadget.

The web gadget is just doing what you have your servers security settings are set for.
73
Roger
W8RJ

Offline m3ghe

  • Moderator
  • Remote Master
  • *****
  • Posts: 761
    • Barney's online radios
Re: Embedding in your own Webpage (Google Gadget)
« Reply #48 on: December 03, 2017, 10:11:27 am »
If you make you server public and no login required you can have the same as me. http://www.remotehams.com/orb.html?id=7108

Offline m0pkz

  • Remote Enthusiast
  • ***
  • Posts: 48
    • M0PKZ blog
Re: Embedding in your own Webpage (Google Gadget)
« Reply #49 on: January 28, 2018, 10:23:09 am »
What about if I wanna transmit via browser? As I didn't get any signal out with my pc microphone?!

Kes-m0pkz

Under Options->Audio Configuration, 3rd party solutions select Unreal Media Server (Flash Player).
In Domain/Host put your outside IP of your server.

If you want to stream audio (just RX) to the webpage see this post about setting up Unreal Media Server.
http://www.remotehams.com/forums/index.php/topic,16.msg18.html#msg18

Make sure port 5119 is opened and forwarded. Also make sure the Windows firewall has an exception for the Unreal Media server.

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2460
Re: Embedding in your own Webpage (Google Gadget)
« Reply #50 on: January 28, 2018, 12:05:50 pm »
Transmit audio is not available with the Browser gadget and Unreal Media Player. Just RX audio.
73
Roger
W8RJ

Offline kb8cr

  • Remote Enthusiast
  • ***
  • Posts: 24
Re: Embedding in your own Webpage (Google Gadget)
« Reply #51 on: July 08, 2018, 05:52:07 pm »
I have it working well, but one concern......Mine DOES allow TX !! How it knows that *I* am the Control-OP I don't know. There is no login. I'm just going to the webpage that I set up to test, and when I click TX, it does.....

Charlie

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2460
Re: Embedding in your own Webpage (Google Gadget)
« Reply #52 on: July 09, 2018, 03:17:10 am »
Yes you can operate a TX button, but there is no TX audio. The use of the TX button your remote will still be governed by who has TX privileges. It uses the credentials saved in the browser for logging into the website. If your server allows Guests (Server Config), than no login is required.
« Last Edit: July 09, 2018, 03:22:35 am by w8rj »
73
Roger
W8RJ

Offline kb8cr

  • Remote Enthusiast
  • ***
  • Posts: 24
Re: Embedding in your own Webpage (Google Gadget)
« Reply #53 on: July 09, 2018, 07:08:45 pm »
Thanks, I'll have to check those settings .  I had the Unreal Server working yesterday, but I can't get it to go today. Is there a particular order that you have to start those programs?

Charlie

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2460
Re: Embedding in your own Webpage (Google Gadget)
« Reply #54 on: July 10, 2018, 04:05:28 am »
You should the Unreal Server running before starting RcForb Server.  Double check you have port 5119 opened and forwarded.
73
Roger
W8RJ

Offline kb8cr

  • Remote Enthusiast
  • ***
  • Posts: 24
Re: Embedding in your own Webpage (Google Gadget)
« Reply #55 on: July 16, 2018, 06:54:19 pm »
I have both Live Server and Unreal Server running before I started RCForb Server. I don't know what I did before that got it to work, but I'll keep trying.

Charlie

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2460
Re: Embedding in your own Webpage (Google Gadget)
« Reply #56 on: July 17, 2018, 04:59:41 am »
Double check that the Windows Firewall (or your anti-virus firewall) has an exception for the Unreal Server. The path to the server on a 64bit computer is

C:\Program Files\UnrealStreaming\UMediaServer\UMediaServer.exe
73
Roger
W8RJ