Author Topic: Pollwait read timeout, Radio Powered Off  (Read 337 times)

Offline n7rvd

  • Remote Enthusiast
  • ***
  • Posts: 15
Pollwait read timeout, Radio Powered Off
« on: November 29, 2017, 08:01:55 am »
followed by...

K3 radio powered on.

The radio is a K2 using the K3 setup option.  It's hooked into a Win10 PC via a usb-RS232 serial port adapter.  No other software is running.

Oddly, sometimes the radio at the client end cuts out for as second or two.  Other times, it receives non-stop even though thios messege is flashing on the server end.

Once, I powered "off" and back "on" the K2 via the client, and it went away.

I tried this again later... no change, no help.

--- Brian N7RVD

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2129
Re: Pollwait read timeout, Radio Powered Off
« Reply #1 on: November 29, 2017, 08:16:47 am »
The K3 driver really doesn't support the K2. the Poll wait timeout is from the radio not answering to request for some information.
73
Roger
W8RJ

Offline n7rvd

  • Remote Enthusiast
  • ***
  • Posts: 15
Re: Pollwait read timeout, Radio Powered Off
« Reply #2 on: November 29, 2017, 09:08:58 pm »
Heck.  Why not write a driver for the K2?   :)

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2129
Re: Pollwait read timeout, Radio Powered Off
« Reply #3 on: November 30, 2017, 05:07:55 am »
73
Roger
W8RJ

Offline m3ghe

  • Moderator
  • Remote Master
  • *****
  • Posts: 747
    • Barney's online radios
Re: Pollwait read timeout, Radio Powered Off
« Reply #4 on: December 01, 2017, 11:10:09 am »
Heck.  Why not write a driver for the K2?   :)
I wonder should that not be "Would it be possible for you to write a driver for the K2?" 🤔

Offline n7rvd

  • Remote Enthusiast
  • ***
  • Posts: 15
Re: Pollwait read timeout, Radio Powered Off
« Reply #5 on: December 04, 2017, 07:24:24 am »
Thank you for the HRD suggestion.  I have a 30 day free trial running right now.

Next, I launched RCForb server which failed of course since the com port was in use by HRD.

After starting the IP server in HRD, I reset the RCForb server option to SDR radio and restarted RCForb.

Zippo.  No go.

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2129
Re: Pollwait read timeout, Radio Powered Off
« Reply #6 on: December 04, 2017, 08:08:25 am »
On the radio Config tab, select via Ham Radio Deluxe. Select HRD V5 for V6

You might want to re-read the post I gave you earlier.
73
Roger
W8RJ

Offline n7rvd

  • Remote Enthusiast
  • ***
  • Posts: 15
Re: Pollwait read timeout, Radio Powered Off
« Reply #7 on: December 05, 2017, 06:27:00 am »
Roger,

This is really getting interesting.  I understood your prior post.  It took me a while to realize that the HDR setting was a button, not a drop down menu item.  I tried both versions 4 and 5 without success.  I did a screen shot of the lengthy error message and posted it in a word doc.  Here's the link:

http://raincityhome.com/HDRerror01.docx

More info:

My K2 is a very early 200 serial number WITH all A to B mods.  It is connected to my Win 10 PC with the custom Elecraft cable, not a standard RS232 cable.  I have been running N1MM, Writelog, Win Commander, MMTTY, etc for almost two decades.

There appears to be an Elecraft Control Board Mod that went into effect for K2 serial numbers 3000 and up.  I have not researched this mod just yet.

Lastly, while I have HDR running right now, I can't send CW.  The DM780 and Rig control can't share the one and only com port.

Brian N7RVD

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2129
Re: Pollwait read timeout, Radio Powered Off
« Reply #8 on: December 05, 2017, 06:55:19 am »
You may have more than one instance of the server running. Check the Window tray. Also double check that the VoIP and Server port didn't get set to the same port. VoIP port should be 4524 (Audio Configuartion)  and the server port 4525 (Server Configuration)

DM780 uses the IP server (not the serial port) in HRD to connect to the radio. Make sure you have the IP server in HRD running (Under Tools menu).
« Last Edit: December 05, 2017, 06:59:04 am by w8rj »
73
Roger
W8RJ

Offline n7rvd

  • Remote Enthusiast
  • ***
  • Posts: 15
Re: Pollwait read timeout, Radio Powered Off
« Reply #9 on: December 06, 2017, 04:57:13 am »
I have the IP server running in HRD.

The port defaults to 7809.  I can overwrite it. 

The RCForb VOIP is set to 4524.  The IP server defaults to 7809.  I can NOT overwrite it to 4525.  It wants to auto-correct to 7809.

I just found the HRD Emulation drop down on the RCForb server menu.  I tried Disabled, V4, and V5 and got the same error message every time:

No connection can be made because the target machine actively refused it.

I did note that the latest (and ONLY) free trial version of HRD is Version 6, not 4 or 5.  It this a problem?

Also, I have had no luck sending CW with DM780.

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2129
Re: Pollwait read timeout, Radio Powered Off
« Reply #10 on: December 06, 2017, 05:07:34 am »
Lets worry about using DM780 to send CW until you get the basic remote working.

1) Start and connect HRD to your radio. Leave it running
2) Confirm HRD's IP server is enabled (Under Tools Menu)
3) In RcForb servers Radio Configuartion page (Radio Connection tab), select via Ham Radio Deluxe
4) For HRD Version 6, select version 5
5) Save and Restart the server. Server should connect to HRD.

No connection can be made because the target machine actively refused it. Where did this message come from, server?


« Last Edit: December 06, 2017, 05:18:17 am by w8rj »
73
Roger
W8RJ

Offline n7rvd

  • Remote Enthusiast
  • ***
  • Posts: 15
Re: Pollwait read timeout, Radio Powered Off
« Reply #11 on: December 06, 2017, 05:22:06 am »
Yes the message came from the server.

I fiddled with the HRD IP settings a bit.....   My new SERVER error messages are:

SetDesiredMaxDelay 400ms

and

Could not start the TcpListener.  Only one usage of each socket address is normally permitted.


Offline n7rvd

  • Remote Enthusiast
  • ***
  • Posts: 15
Re: Pollwait read timeout, Radio Powered Off
« Reply #12 on: December 06, 2017, 05:26:40 am »
I just double checked what i changed to get the different error messages....

In the IP Server window I unchecked the box: Same PC Connections only.


Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2129
Re: Pollwait read timeout, Radio Powered Off
« Reply #13 on: December 06, 2017, 05:27:54 am »
Put TeamViewer on your server computer and private message me the ID and password.

http://www.teamviewer.com
73
Roger
W8RJ

Offline n7rvd

  • Remote Enthusiast
  • ***
  • Posts: 15
Re: Pollwait read timeout, Radio Powered Off
« Reply #14 on: December 06, 2017, 05:38:25 am »
PM sent.

I just reread my earlier posts.  I've learned a lot the past 2 days.