Author Topic: FT-991 power off -> RadioSetState is Busy  (Read 979 times)

Offline w6ipa

  • Just starting...
  • *
  • Posts: 3
FT-991 power off -> RadioSetState is Busy
« on: November 26, 2017, 07:18:16 pm »
Hi -
I'm experimenting with RFCOrb Server and an FT-991a connected through usb.
Every thing seems to work, except turning off the radio through the client (Android)

The radio does turn on, and turn back on when requested, but then the client loose control and audio and I see this on the server console:
- Turning Radio On
- VoipServer: Exception processing mic samples ,....
- Radio Failed to turn on
- RadioSetState is Busy


My feeling is that when the radio is turned off the usb drivers are somewhat closed, and when the radio is powered on,
they are re loaded (windows is playing the jingle as when you connect a new device)

The only way out if this seems to restart the server.

I am very new to RFCOrb, and I may be doing something wrong.

Thanks for any help.

JC

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2352
Re: FT-991 power off -> RadioSetState is Busy
« Reply #1 on: November 27, 2017, 02:04:52 am »
We did have an issue awhile back with turning the power on, so make sure you have the latest server (http://download.remotehams.com)

Also make sure you have the latest serial port driver from Yaesu.

Your diagnoses on the sound device sounds correct, but it shouldn't be doing that. If Windows is losing the sound device on power up, it sounds like it may be a firmware problem. I know Yaesu brought out a firmware update in October 2017. Is that the firmware you have loaded? If not update the firmware.

I assume the Windows Client does the same thing??
« Last Edit: November 27, 2017, 08:38:01 am by w8rj »
73
Roger
W8RJ

Offline w6ipa

  • Just starting...
  • *
  • Posts: 3
Re: FT-991 power off -> RadioSetState is Busy
« Reply #2 on: November 27, 2017, 08:58:21 am »
Yes, I have the latest of everything : Upgraded the radio, windows (10), the SI drivers, and RFCOrb server.
It seems that not only the sound device is missing, but also the com port. which may confuse the server.

JC

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2352
Re: FT-991 power off -> RadioSetState is Busy
« Reply #3 on: November 27, 2017, 09:24:36 am »
Are you connected to the "enhanced" serial port.

Look in the windows device manager and when the radio is turned off, does the serial port and/or the sound device goes away? If that is the case, there is nothing we can do. I do know the firmware version before the one in October worked.

If you are and it's still misbehaving contact me on Skype remotew8rj  and /or install TeamViewer (http://www.teamviewer.com)on the server machine and let me remote in. You can private message me with the TeamViewer credentials
« Last Edit: November 27, 2017, 09:48:01 am by w8rj »
73
Roger
W8RJ

Offline w6ipa

  • Just starting...
  • *
  • Posts: 3
Re: FT-991 power off -> RadioSetState is Busy
« Reply #4 on: November 27, 2017, 10:03:39 am »
Thanks, I will double check.
On a related note, if the rig is off when the server is starting, it tries to start the radio, but then fails to communicate with it and hang.
The error is Yaesu()->Connect()-> Unable to parse Frequency

JC

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2352
Re: FT-991 power off -> RadioSetState is Busy
« Reply #5 on: November 27, 2017, 10:26:20 am »
Yes, the server attempts to turn the radio on when starting if the radio is off.

It sounds like when the power is off, the power is also removed from the serial port and audio devices. If that is true, Yaesu changed that with the last firmware.
73
Roger
W8RJ