Author Topic: UFW settings for RCForb on a VM on Mint  (Read 620 times)

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 1809
Re: UFW settings for RCForb on a VM on Mint
« Reply #15 on: July 06, 2017, 08:59:20 am »
There is logic in the Kenwood driver to show that message when the driver doesn't know or the driver chooses to ignore a command. But the examples you gave makes no sense, unless there are undocumented commands not shown in the 570 manual. I don't rule that out as a possibility. The only commands I would expect to see displayed like your example, would be commands starting with EX.

I think a better answer would be the serial traffic from the radio is getting corrupted. On the Radio Config, you should not have RTS or DTR enabled and if you're using Serial PTT, it can't be the same comport using RTS for PTT.

Kenwood radios use hardware handshaking, which utilize the RTS signal line. Therefore you can't use the RTS line on the radios serial port for other purposes.
« Last Edit: July 06, 2017, 09:01:23 am by w8rj »
73
Roger
W8RJ

Offline n3mow

  • Remote Enthusiast
  • ***
  • Posts: 18
Re: UFW settings for RCForb on a VM on Mint
« Reply #16 on: July 07, 2017, 05:20:10 pm »
Roger,

I have my setup working. I tested it on two separate pcs running the client. Noticed a lot of those error messages (see last post) from the TS-570. Makes me think that I might have the rs-232 data rate too high. Maybe I should reduce it to 4800. What do you think? I'd like to get rid of the extraniious data.

Thanks,
Marty N3MOW

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 1809
Re: UFW settings for RCForb on a VM on Mint
« Reply #17 on: July 08, 2017, 05:02:56 am »
You could try reducing the serial port baud rate, but I don't think that's the issue.

My best guess it's some kind of setup issue in your virtual machine, or hardware/driver issue.

I assume you're using some kind of USB to Serial adapter. If it's an adapter that uses the Prolific chipset, that may be an issue. I do know that Windows 7 and later have problems with the Prolific chipset and I wouldn't be surprised there would be problems with a virtual machine, regardless of what guest OS you're using. Again this is just a guess.
73
Roger
W8RJ

Offline n3mow

  • Remote Enthusiast
  • ***
  • Posts: 18
Re: UFW settings for RCForb on a VM on Mint
« Reply #18 on: July 08, 2017, 06:41:39 am »
Roger,

You are correct I'm using a usb to rs-232 adapter cable made by radio shack. I believe it is built on the prolific chipset. I'm using Virtual Box 5 on Linux Mint 18 and the guest OS in Windows XP. I have used this cable on my main station PC running Mint 17.1 and CQRLog with no apparent problems. I do agree that the problem could be related to the cable or the virtual machine setup. Virtual machines are a new concept for me so I do not know where to look to resolve this issue. Would you suggest some areas to check in my VM or host. Should I just ignore the spurious data? Will that get cause trouble later down the road?

73
Marty, N3MOW

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 1809
Re: UFW settings for RCForb on a VM on Mint
« Reply #19 on: July 08, 2017, 07:54:53 am »
I really don't have much experience with Virtual machines nor Linux. Google is your friend on that one.

It still could be the Prolific chipset as the typical logbook program doesn't put a large demand on a serial port, where as RcForb server does. As to it causing problems I can't give you a definitive answer.
73
Roger
W8RJ

Offline n3mow

  • Remote Enthusiast
  • ***
  • Posts: 18
Re: UFW settings for RCForb on a VM on Mint
« Reply #20 on: July 11, 2017, 12:14:33 pm »
Roger,

Started my RCForb server to day to continue testing. Same setup that I had working before. No I'm having a problem connecting to the TS-570. The usb converter cable is connected and seen in Linux mint. The vm has com1 directed to /dev/ttyUSB0. The baud rates on VM and radio are the same all cables are connected as before. The radio is on and connected to the usb cable.

When I start the server the following messages are displayed:

Offline n3mow

  • Remote Enthusiast
  • ***
  • Posts: 18
Re: UFW settings for RCForb on a VM on Mint
« Reply #21 on: July 11, 2017, 12:29:13 pm »
To Continue -

Error messages:

info connecting to radio
RCForb server free
error radio connection problem Generic
failed to start !_app.Open()

The VM guest OS (XP) did add support for the Prolific pl2303 cable. I tried both this device and the one that had worked before. Same error on both. I do not see what has changed. Should I try to remove the new prolific driver?

Sorry for the disjointed post. All suggestions are welcome.

73
Marty, N3MOW

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 1809
Re: UFW settings for RCForb on a VM on Mint
« Reply #22 on: July 11, 2017, 01:18:42 pm »
Confirm there's not two instances of the server running.

Other than that the console shows it's simply not being able to connect to the radio.

Just a thought, does your XP virtual machine have SP3? Even though .NET 4 shouldn't install unless its XP SP3, I have seen .NET installed without SP3.
« Last Edit: July 11, 2017, 03:54:24 pm by w8rj »
73
Roger
W8RJ

Offline n3mow

  • Remote Enthusiast
  • ***
  • Posts: 18
Re: UFW settings for RCForb on a VM on Mint
« Reply #23 on: July 16, 2017, 08:37:48 am »
Roger,

Following your suggestion I took a good look at the configuration of the XP VM. I do have SP3 installed and Framework 4 has all the upgrades from Microsoft installed. I installed the driver for the usb/rs-232 cable from Prolific. When I checked the device manager to look at the com and usb ports I was surprised to find that usb support was not installed. After installing usb support the prolific cable was installed on com3. I deleted the setup for com1 in the VM to go to the host usb. I found that setting the radio port in RCForb to com3 worked perfectly. Connection to the radio completes much faster now. I think that's about all I can do with the VM.

I'm still getting the weird data displayed on the console. Put the problem out on the TS-570 yahoo group. Got one good answer and that was to split the rs-232 output between the radio and PC so it could be monitored by another PC terminal program. This would show if it is the radio or not. If the extra data is not harmful, I do not know if constructing a splitter would be worthwhile.
What do you think? Would I be better off using HRD to control the radio?

Are there still problems using AVG with RCForb server? I need an antivirus for the VM. I do not know if the Linux firewall is enough.

Thanks again for your continued support.

73
Marty, N3MOW

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 1809
Re: UFW settings for RCForb on a VM on Mint
« Reply #24 on: July 16, 2017, 10:25:47 am »
Adding HRD is probably just going to complicate your problems. As to an Anti-Virus program, that's up to you.

I can't give you a definitive answer regarding the unknown data, as none of the examples you gave make any sense. All Kenwood CAT commands start with two ASCII characters, and non of your examples correspond to any published commands for the 570. I still would be suspicious of the Prolific USB to Serial adapter.

73
Roger
W8RJ