Author Topic: WSJT-X on Remote TS-2000, TXd Not Allowed  (Read 2239 times)

Online w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2137
Re: WSJT-X on Remote TS-2000, TXd Not Allowed
« Reply #15 on: July 14, 2017, 10:26:10 am »
It's being worked on right now. FYI, V9 of the Client doesn't have the problem.
73
Roger
W8RJ

Offline dd5xx

  • Remote Enthusiast
  • ***
  • Posts: 39
    • QRZ.com webpage of DD5XX
Re: WSJT-X on Remote TS-2000, TXd Not Allowed
« Reply #16 on: July 14, 2017, 11:03:54 am »
nice to hear that. Yeah, I have installed 0.9 long time ago, but unfortunately still Alpha and I got some issues with it (lagging, hanging). That's why I still work with 0.8 although I'd like to have the "GO ROTATOR" feauture which will send a signal to the rotator and turn it. But 0.8 is ok for me now.

Would be looking forward to get a reply here on that thread, when fix for 0.8 version will get ready. Thanks a lot for your effort dear OM.

73

Offline kg6ypi

  • Administrator
  • Remote Master
  • *****
  • Posts: 1332
    • RemoteHams.com
Re: WSJT-X on Remote TS-2000, TXd Not Allowed
« Reply #17 on: July 14, 2017, 05:11:54 pm »
Virtual K3 in RCForb Server has been updated
http://download.remotehams.com/debug/RCForb_Server_Setup_0.7.exe

Virtual K3 in RCForb Client v0.8 has been updated
http://download.remotehams.com/debug/RCForb_Client_Setup_0.8.exe

Let me know if this solves your issue.

Offline dd5xx

  • Remote Enthusiast
  • ***
  • Posts: 39
    • QRZ.com webpage of DD5XX
Re: WSJT-X on Remote TS-2000, TXd Not Allowed
« Reply #18 on: July 16, 2017, 12:32:18 am »
Great, THANK YOU Brandon! works like a charm.

73 de DD5XX
Saki

Offline dd5xx

  • Remote Enthusiast
  • ***
  • Posts: 39
    • QRZ.com webpage of DD5XX
Re: WSJT-X on Remote TS-2000, TXd Not Allowed
« Reply #19 on: July 31, 2017, 11:56:25 pm »
After testing a while I experienced audio issues. I listen from other (my own) radio at home and/or through WebSDR stations to check the signal and audio on RX side. The audio that I transmit with my computer (WSJT-X 1.8. RC1 + RCforb client 0.8.6404.30885) starts nice for a second or too and then immediately transforms into a distorted soun, like overdriven, just like a gain loop. I tested also on two other computers where I run this combination with WSJT-X + RCforbclient and regardless the audio levels I have the same issue. WSJT-X generates the audio wave which is send out through VB Audio Cable into RemoteHams client. I have picked this audio wave and recorded it, it is 100% perfect and clear. The issue must start somewhere on RCforb client side in my understanding. The issue seems to occur on JT9/65 andFT-8. I am not sure how and why this happens.

does the version you posted before (RCforb client 0.8.6404.30885) still use the latest Opus codec or maybe it's the old speex codec that cause the trouble?

any clues ?
« Last Edit: August 01, 2017, 05:06:25 am by dd5xx »

Online w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2137
Re: WSJT-X on Remote TS-2000, TXd Not Allowed
« Reply #20 on: August 01, 2017, 05:42:42 am »
This is a known issue with digital modes, especially ones that tend to be more "musical".

The Opus codec won't be implemented until the new server (V 9) is released.
73
Roger
W8RJ

Offline dd5xx

  • Remote Enthusiast
  • ***
  • Posts: 39
    • QRZ.com webpage of DD5XX
Re: WSJT-X on Remote TS-2000, TXd Not Allowed
« Reply #21 on: August 01, 2017, 05:44:19 am »
Does that mean that all other RCforb client user out there currently cannot work JT/FT mode at all ?

You mean RCforb client 0.9 version or does the server also need to run the 0.9 version to have Opec work ?

Online w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2137
Re: WSJT-X on Remote TS-2000, TXd Not Allowed
« Reply #22 on: August 01, 2017, 05:58:54 am »
I believe some users have better luck than others. You can try adjusting the audio levels (server and/or client) to see if you can find a good level.

Of course, Server and Client need to be using the same codec.
73
Roger
W8RJ

Offline dd5xx

  • Remote Enthusiast
  • ***
  • Posts: 39
    • QRZ.com webpage of DD5XX
Re: WSJT-X on Remote TS-2000, TXd Not Allowed
« Reply #23 on: August 01, 2017, 06:10:48 am »
there are only two audio levels one can adjust for affecting the "output" power. One of them is the slider in WSJRT-X on the right side which is called "PWR digital gain" and the other one is the MIC-level in RCforb client. Believe me, I have tried dozens of combinations of them but none of them led to a successful result. Even when the level is very low the distortion occurs after few seconds and thus make the connection impossible. Decode works fine though, these audio signals are sounding ok and WSJRT-X can decode a lot of station. When I am sending CQ or trying to reply to a CQ I am left quite unresponsed which is very very unusual.

Offline va7cab

  • Remote Enthusiast
  • ***
  • Posts: 21
Re: WSJT-X on Remote TS-2000, TXd Not Allowed
« Reply #24 on: August 08, 2017, 05:58:38 pm »
There is no way to solve this problem consistently. I've tried and the speex codec just does not function with JT-65.

Today I tried using FT8 and while I was able to send a few CQ's with an audio tone above 1500 Hz, it presented that weird feedback distortion after a minute or so. Tones sent below 1500 Hz will distort immediately.

Currently I'm using RemAud to bypass RCForb audio entirely and some people use Skype. I've been doing this fine with JT-65 and JT-9, but FT8 poses a problem because of the very fast turn around time from RX to TX. RemAud introduces just enough delay to make QSOs problematic.

I'm sure RCForb will be great when speex is replaced by Opus and I can't wait because other than having to use a 3rd party app for audio RCForb rocks.

Chris VA7CAB


Offline k0jd

  • Just starting...
  • *
  • Posts: 4
Re: WSJT-X on Remote TS-2000, TXd Not Allowed
« Reply #25 on: October 17, 2017, 09:08:57 pm »
Before i put in the client/server setup, I ran WSJT-X REMOTELY via VNC - a system where you gain full-screen remote access to a computer. If data modes were set up properly, you just run WSJT-X as if you were there. Since no audio is fed over codecs that can't handle the multiple tones of a cluster of FT8 warbles, you don't have distortion issues and no time delay issues. It is fun to play with RCForb, but it just doesn't seem suitable for WSJT-X running on a remote computer at this time. Obviously to access all the radio's settings you have to quit WSJT-X and start the server, but once you're sure you have data setup properly, quit the server, start WSJT-X, and go to town.

Offline ac7cw

  • Remote Enthusiast
  • ***
  • Posts: 21
Re: WSJT-X on Remote TS-2000, TXd Not Allowed
« Reply #26 on: December 10, 2017, 05:57:11 pm »
Before i put in the client/server setup, I ran WSJT-X REMOTELY via VNC - a system where you gain full-screen remote access to a computer. If data modes were set up properly, you just run WSJT-X as if you were there. Since no audio is fed over codecs that can't handle the multiple tones of a cluster of FT8 warbles, you don't have distortion issues and no time delay issues. It is fun to play with RCForb, but it just doesn't seem suitable for WSJT-X running on a remote computer at this time. Obviously to access all the radio's settings you have to quit WSJT-X and start the server, but once you're sure you have data setup properly, quit the server, start WSJT-X, and go to town.

I've been working FT8, seems fine. I use RCForb with the emulated K3 for the radio, installed WSJT-X and was up and running in no time. The remote radio is a TS-2000.