Author Topic: Conneting ICOM IC-706MKIIG to RCForb server 0.7  (Read 1744 times)

Offline sm4kuh

  • Just starting...
  • *
  • Posts: 8
Conneting ICOM IC-706MKIIG to RCForb server 0.7
« on: November 21, 2016, 02:23:00 pm »
Hello.

When I configure the PTT to RTS on the samre port as the Radio connection the server get Error: Rado connection problem. All exept TX works when i don't have the PTT via com configured.

/Christer SM4KUH

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2198
Re: Conneting ICOM IC-706MKIIG to RCForb server 0.7
« Reply #1 on: November 21, 2016, 04:32:26 pm »
First what kind of sound card interface unit are you using? It may be a setup issue with the sound card interface unit.

The following assumes that all you have setup is the Serial connection to the radio.

It sounds like your CI-V cable needs the RTS set high to power the level convertor in it. That's why you can connect to the radio, when you have RTS checked on in the Radio Connection.

Since your 706 doesn't have a CI-V command for transmit (PTT), you will need second Serial Port for PTT.

The link below is a cable can be used for your PTT. It will use the DTR pin, so you need to set up the PTT to use the second serial port and use the DTR pin. Since the cable has a 1/4 plug on one end, you will have to adapt it to wire into the PTT on the radio

http://www.newegg.com/Product/Product.aspx?Item=9SIA3XT1D87045
73
Roger
W8RJ

Offline sm4kuh

  • Just starting...
  • *
  • Posts: 8
Re: Conneting ICOM IC-706MKIIG to RCForb server 0.7
« Reply #2 on: November 23, 2016, 05:49:16 am »
I am using a computer with serialport, nu usb interface or somthing like that.
The CI-V cable uses DTR for power. When I set RTS high the rig transmits.
Another rig-control program is working with the same cable and only one serialport. (IC-706_BKT)

/Christer - SM4KUH

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2198
Re: Conneting ICOM IC-706MKIIG to RCForb server 0.7
« Reply #3 on: November 23, 2016, 06:01:14 am »
If the cable uses DTR for power you should setup as follows.

In Radio connection, you should have RTS unchecked, DTR checked.
On PTT setup, via Com, select same com port as the radio, and select Use RTS

***Update***

I just checked the driver code and it looks  like the DTR pin is not being set high as it should be. I'll let you know when and installer with a fix is available
« Last Edit: November 23, 2016, 06:08:44 am by w8rj »
73
Roger
W8RJ

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2198
Re: Conneting ICOM IC-706MKIIG to RCForb server 0.7
« Reply #4 on: November 23, 2016, 06:27:54 am »
Although it's not completely fixed, here is a workaround

If the cable uses DTR for power you should setup as follows.

In Radio connection, you should have RTS unchecked, DTR checked.

On PTT& CW Keying Setup
1) Select via Com, select same com port as the radio, and select Use RTS
2) Make sure under "External CW Keying" neither "Use RTS" nor "Use DTR" are checked. You may have to temporarily enable "CW Key" to uncheck both those boxes. Make sure you disable CW (Key) after making those changes.
« Last Edit: November 26, 2016, 04:27:29 am by w8rj »
73
Roger
W8RJ

Offline sm4kuh

  • Just starting...
  • *
  • Posts: 8
Re: Conneting ICOM IC-706MKIIG to RCForb server 0.7
« Reply #5 on: November 24, 2016, 11:09:44 am »
Thank You
Now working OK  :D

/Christer, SM4KUH

Offline sm4kuh

  • Just starting...
  • *
  • Posts: 8
Re: Conneting ICOM IC-706MKIIG to RCForb server 0.7
« Reply #6 on: November 26, 2016, 01:26:29 am »
Hello.
I have now enabled the CW funktion on another com-port, and it works when I use the RTS signal. When I use the DTR-signal it stops communicating with the IC-706.

Just for info,

/Christer - SM4KUH

Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2198
Re: Conneting ICOM IC-706MKIIG to RCForb server 0.7
« Reply #7 on: November 26, 2016, 05:03:53 am »
Thanks for the information, it's somewhat related to the same bug that you encountered before.
73
Roger
W8RJ

Offline ac7av

  • Remote Enthusiast
  • ***
  • Posts: 18
Re: Conneting ICOM IC-706MKIIG to RCForb server 0.7
« Reply #8 on: November 18, 2017, 09:18:41 am »
Hi Roger,
I realize this topic is a few days old, but its exactly what I'm having some trouble with.  I have the Icom IC706MK2G that I am trying to get working on the server.  I can not get the TX to work using the settings listed here.  Has anything changed on the program that I need to change since this was posted?  I am using the CV-I USB cable, the radio connected just fine, just no PTT threw that cable on the server.  The radio will TX on other radio control programs threw the cable, and I tried to copy those settings exactly, but I may be missing something. 


Offline w8rj

  • Moderator
  • Remote Master
  • *****
  • Posts: 2198
Re: Conneting ICOM IC-706MKIIG to RCForb server 0.7
« Reply #9 on: November 18, 2017, 10:09:18 am »
I discovered a small bug in the Icom driver when sorting out RTS and DTR pin use and it's fixed but not published.

Since you're using USB cable to connect to the radio, you shouldn't have to use DTR or RTS on the radio connection tab. Older CI-V cables needed RTS or DTR to power the Max-232 chip, but with USB the chip gets powered off the USB bus. So disable those for now and see if the radio does connect up.

On the CW & PTT tab select "via Com" and the select RTS or DTR. (Probably RTS).

Make sure on the External CW, that neither RTS or DTR is checked. If they are greyed out, temporarily enable External CW and uncheck both.

If all this doesn't  work let me remote in with the fixed driver. Private message me with your TeamViewer credentials.
73
Roger
W8RJ